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ABSTRACT
When an electrical conducting volume is placed into the bore of an MRI undergoing an
image scan, time varying magnetic gradients induce eddy currents in this conducting material.
These eddy currents in turn produce a mechanical torque on this volume. It is the goal of this
thesis to produce a computer simulation of eddy currents produced by placing conducting
materials inside an MRI bore. The first part of the thesis establishes the physics and principles
behind an MRI system along with several applications. Next, this thesis presents an analysis of
eddy current effects produced on a conductor placed into an MRI bore. The design and
construction of simulated MRI magnetic fields is then presented along with a study of simulated
eddy currents in various test conducting volumes of selected materials. Finally, techniques are
discussed for reducing eddy currents in these conducting volumes and materials, along with
simulation results showing the reduction in the applied eddy current. The findings of this thesis
are summarized in the conclusions and recommendations are made for modification and future
applications of these techniques and simulations.
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CHAPTER ONE: INTRODUCTION
There are three major groups of problems associated with eddy currents related to the use
of Magnetic Resonance Imaging (MRI). The first group includes the effects of eddy currents on
the image quality. This includes effects caused by eddy currents in the gradient coils
themselves1,2,3,4 and the MRI structural components.5 The second group includes physical effects
inside the body of a patient (implants and the body itself) undergoing an MRI scan.6 The third
group includes the physical effects caused by eddy currents outside the body, and is the focus of
this thesis.i
A typical medical MRI contains a large electromagnet capable of creating a static
magnetic field in the range of 0.5 Tesla (T) to 3.0 T with a uniformity across the bore of 0.5 parts
per million (ppm). The central volume, in which patients are placed, is called the bore. Research
MRI bore magnets can create fields exceeding 14.0T. This static magnetic field within the bore
is used to align the billions of atoms in the human body (or other object), which are primarily the
hydrogen atoms of water molecules. Because hydrogen atoms have a single proton and single
electron, these atoms have a large magnetic moment and thus are more easily measured than
other atoms. Although the vast majority of the atoms will line up in one direction or the other
along the lines of magnetic flux, canceling each other’s bulk magnetic moment, there will be
sufficient numbers of atoms that are not cancelled to give a sufficient “signal” to be detected.

i

S. D. Fisher, Chief Engineer, Invivo Research, Inc. (personal communication, 6 June

2007)
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In order to create a “signal” that can be detected from a hydrogen atom, it is excited by an
external radio frequency (RF) pulse at a precise frequency called the Larmour frequency (42.57
MHz / Tesla for hydrogen).7 The Larmour frequency is based on the hydrogen atom itself and
the applied magnetic field strength. When the RF pulse is applied, it causes most of the hydrogen
atoms to spin (precess) in a manner that causes the dipole moment of the hydrogen atoms to
rotate 90 degrees to an unstable state (non-aligned) and store energy imparted by the RF pulse.
When the RF pulse terminates, the hydrogen atoms naturally tend to re-align themselves with the
static magnetic field and release the stored energy. During the time when the hydrogen atoms
naturally tend to re-align themselves with the static magnetic field, this stored energy is reradiated as RF energy at the Larmour frequency and is detected by receiving electronics. The
amplitude of this signal is dependent on the density of the hydrogen atoms present.
The discussion in the previous paragraph produces a signal that has no dependence on
spatial information. To spatially encode a signal, the static magnetic field within the MRI bore is
spatially modulated. Coincidentally with the application of the RF pulse, there are a number of
“gradient coils” in an MRI, typically aligned to create magnetic field variations in the x, y, and zaxes. These gradient coils alter the magnetic field created by the bore magnet on a specific and
local level, typically less than one-eighth of a cubic millimeter. The main purpose of the gradient
coils is to spatially modulate the magnetic field within the MRI bore. Since the different spatial
positions within the MRI bore will have a different magnetic field strength, the Larmour
frequency of the proton precession will be different at these spatial positions. Hence, the signal
generated in the MRI bore will be dependent on the spatial position. Typically the x-axis is
frequency encoded while the y-axis is phase encoded. An accumulation of the detected energy
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along each of the three axes is then assembled to create a two-dimensional or a threedimensional image of the subject.
In many cases, a patient undergoes MRI testing in conjunction with other tests. These
additional tests may require RF receive and transmit coils, instrumentation, wires, sensors, and
other devices attached to the patient or the MRI system. The current in the gradient coils of an
MRI are changed rapidly, and this rapid change in magnetic field induces eddy currents in
electrically conducting materials exposed to these time varying magnetic fields. The induced
eddy currents in these materials induce a torque, causing discomfort and annoying effects to
patients in the form of vibrations and acoustic noise. Additionally, and more importantly,
electronics associated with the ancillary test equipment typically contain integrated circuits,
resistors, capacitors, and other electronic components. These electronic components contain
conductors that when placed in time varying magnetic fields produce eddy currents. This can
lead to stress on these components. Furthermore, metal materials such as aluminum, copper, or
other composite metals are typically used in the manufacturing of electronic enclosures or
mechanical fasteners. It is this conducting material that contributes to the annoying vibration and
acoustic effects. Also, the RF transmit and receive coils are composed of loops of copper wire.
When the static magnetic gradient field is incident on these coils, these coils also undergo the
same vibration and acoustic stresses from the eddy current effects.
It is the purpose of this thesis to develop a computer simulation model of the MRI bore
and gradient fields. Next, the functional performance of the computer simulation is verified.
Using a sine wave gradient signal, the eddy currents in several geometrical shaped objects are
simulated. The torque of these objects is then measured from the computer simulation. A
comparison is made between these geometrical objects to determine which object produces the
3

lowest eddy current or torque. Other experimental simulations are performed to determine if
adding various types of holes in a material can reduce the eddy current in the object.
Chapter one (this chapter) introduces the concept of eddy currents in an MRI
environment, an overview of the MRI system, and the plans for developing solutions for
reducing eddy currents in an MRI environment. Chapter two lays the foundational physics
behind induced currents and the creation of magnetic fields with some history of Faraday’s Law,
Lenz’s Law, and Ampere’s Law. Chapter three provides a brief discussion of eddy currents in a
general sense and begins the process of establishing the coordinate spaces in which eddy currents
exist. Chapter four describes the physics and concepts of the MRI system. Chapter five begins
the connection of the concepts of chapter three and four with a discussion of eddy currents in the
MRI system and establishes the coordinate system and geometry of an eddy current for the
remainder of the thesis. Chapter six establishes the validity of the Maxwell 3D electromechanical
analysis software with reference geometries and physics comparisons as well as modeling of the
MRI components and system. Chapter seven describes the various test volumes used in this eddy
current analysis and the results. Chapter eight continues with a presentation of test volumes with
incorporated eddy current reduction features and simulation results. Chapter nine completes this
thesis with a presentation of the overall concepts and comparison of the simulation results.
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CHAPTER TWO: INDUCED CURRENTS
The MRI brings together a number of fundamental principles in physics and engineering.
A brief reminder of the principles involved, and how they are used, will be sufficient to form the
foundation upon which the principles of eddy current reduction techniques can be implemented.

Faraday’s Law
Faraday’s Law, which essentially states that a changing magnetic field produces a
corresponding electric field, and thus a current in a conductor, is fundamental to understanding
the effects of eddy currents. In the case of the MRI, the magnetic field is changing due to
changes in current through the gradient coils. This changing magnetic field produces currents in
conductive materials exposed to the MRI magnetic fields.8

5

Figure 1.

Induced Current

The graphic of Figure 1 demonstrates Faraday’s Law showing a rotating magnetic field
inducing a current in a conductor. Faraday’s relationship is expressed as follows, where B is the
magnetic field and E is the electric field:

E

- B/ t

(1)

This equation essentially states that the electric circulation is proportional to the change
in the magnetic field over time. The negative sign indicates the “left handedness” of the effect.
(If one uses the right hand rule, and curls the fingers in the direction of the electric field, the
thumb will point in the “negative” direction of the magnetic field.)

6

Lenz’s Law and the Lorentz Relation
Lenz’s Law describes the directionality of forces upon conductors in motion relative to a
magnetic field. In general, Lenz’s law states that the induced current in a circuit tends to oppose
the action that created it.9 An induced current in a conductor will produce a magnetic field that
opposes the inducing magnetic field. The magnitude and directionality of the forces on a
conductor follow the Lorentz relation, where q0 is the charge and v is the velocity vector:

F = q0E + q0v x B

(2)

In the MRI system there typically is no applied electric field, so the contribution of force
due to charged bodies in an electric field can be eliminated and the equation reduced to:

F = q0v x B

(3)

Furthermore, since a current is an assembly of moving charges, the equation can be
modified to replace the charge and its associated velocity vector with the current, i:

F = il x B

(4)

Equation 4 takes into account the volume of interest, the number of charges in the volume
and the vector direction of the charge movement.

7

Figure 2.

Current Flow

The picture shown in Figure 2 illustrates Lenz’s Law. With the north pole of the magnet
moving toward the conducting loop (straight red arrow), a current is induced in the loop (curved
blue arrow), that will oppose the motion of the magnet. Using the right hand rule for current
flow, the magnetic field of the current loop has a north pole pointing towards the magnet.

Ampere’s Law
In contrast to Faraday’s Law and Lenz’s Law, which establish the foundation for induced
currents and the forces acting on conductors, produced by external magnetic fields, Ampere’s
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Law establishes the foundation for understanding the magnetic field produced by a currentcarrying conductor. Ampere’s Law, which was later enhanced by Maxwell, establishes the
quantitative relationship between the current in a conductor and the magnetic field produced as a
result. Extending Ampere’s Law to the special case of a solenoid, the magnitude of the magnetic
field inside the solenoid can be calculated by:

B0 =

0ni0

(5)

where B0 is the magnitude of the magnetic field,

0

is the permeability constant 4

x 10-7

Henries per meter, n is the turn per length ratio (n = N/L, where N is the number of turns and L is
the length of the solenoid), and i0 is the current through the solenoid. The permeability constant
assumes that the solenoid encloses a vacuum. The permeability constant in the equation above
can be replaced by:

=

0k

(6)

where k is the relative permeability of the material enclosed by the solenoid. In the case of air,
the relative permeability is 1.0000004.10
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CHAPTER THREE: EDDY CURRENTS
A current is induced in a conductor and its direction and associated forces are established
using Faraday’s Law and Lenz’s Law. These concepts are initially considered using a conductor
that is dimensionally large in one axis only – a wire.

Figure 3.

Eddy Currents

A conducting sheet, as shown in Figure 3, can be regarded as a parallel combination of
conducting wires.11 When exposed to a time varying magnetic field, a mechanical motion
relative to a stationary magnetic field, or a combination of time varying magnetic fields and
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mechanical motion, currents are induced in the conductor and forces act upon the conductor to
oppose its motion. For example, a powerful magnet moved across the surface of a conducting
sheet of copper will cause the sheet of copper to move in the same direction as the magnet. (A
similar effect occurs in all conductors. This effect cannot be seen in ferromagnetic materials as
the relative motion is overpowered by the magnetic attraction.) This motion “opposes” the
change in the magnetic field. Given a perfect copper sheet with no electrical resistance, no
frictional losses, and no thermal losses, the sheet would follow the magnet at the same rate.
However, due to losses, the copper sheet will eventually fall away from the magnet.
Using Figure 3 to illustrate, the conducting sheet is moved through a static magnetic field
as shown by the solid green arrows pointing to the right from the edge of the conducting sheet.
By Lenz’s Law, a current is set up in the conducting sheet that creates a force to counteract that
movement. The differential wire elements, indicated with light blue dashed vertical lines, that are
immersed in the B field, conduct current upwards, as indicated by the circulating red current
loop. Using the cross product of the current and the B field, the counteracting force is towards
the left of the figure. The horizontal sections of the current create forces upwards and
downwards, cancelling each other out. The current path outside the B field has no component of
force and thus contributes nothing to the overall counteracting force on the conducting sheet. The
net result is that the force due to the eddy current points to the left to oppose the applied force to
the right. The same effect occurs if the B field is increased. The conducting sheet tends to get
pulled further into the field.
It is important to establish a distinction here in nomenclature. An eddy current is the
current established when the magnetic field is changed while the conductor is stationary. When
the conductor is moved and the magnetic field is stationary, the current induced in the conductor
11

is a Foucault current. However, this distinction has no basis in physics as the results are identical.
One can simply alter the spatial coordinate system to change one to the other. Furthermore, the
term “eddy current” is so much more prevalent in the engineering community that it will be used
throughout this thesis regardless of which spatial reference is in motion.
If a constant magnetic field is established in one direction, and a conducting volume is
passed perpendicular through the field, the differential wires entering the magnetic field first will
have a current induced that will be larger than the differential wires further away from the
magnetic field.
Since the resistivity of the conductor is uniform, the induced current will establish an
induced voltage on the first differential wire that is larger than the second differential wire. The
lower voltage on the second differential wire will allow a return path for current flow from the
first differential wire, thus allowing the induced magnetic field that opposes the motion of the
conducting volume.
In contrast, the differential wire adjacent to the first differential wire, parallel to the
magnetic field (in a conducting volume), will at the same time as the first differential wire, have
an identical induced current, a resulting identical voltage, and thus prevent current flow parallel
to the magnetic field. Therefore, no forces will act on the conducting volume parallel to the
magnetic field.
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CHAPTER FOUR: MAGNETIC RESONANCE IMAGING
MRI Coordinate System
The MRI system defines the three mutually orthogonal directions as axial, or up-field and
down-field, corresponding to the +z and –z directions, respectively. A human subject is placed in
the MRI with the up-field or –z direction at the head and the +z direction towards the feet. The
sagittal direction corresponds to the x direction with +x at the subject’s left and –x at the
subject’s right. Finally, the coronal directions are indicated with +y at the front of the body, or
upwards, and –y at the back of the body, towards the floor.12 The isocenter of the magnetic
system defines the intersection of the axial, coronal, and sagittal planes.

Figure 4.

MRI Coordinate System
13

Figure 4 illustrates the three-dimensional coordinate system employed in MRI systems.

Figure 5.

MRI Coordinate Nomenclature

Figure 5 indicates the nomenclature of each of the three mutually orthogonal planes and
their directionality.
14

MRI Basics

The Human Body
Approximately 63% of the human body is composed of hydrogen atoms.13 For this
reason, MRI of the hydrogen atom is of primary interest in medical MRI measurements.

Proton Spin
The hydrogen atom consists of a single proton and single electron. Each of the
elementary particles in the hydrogen atom, the proton and electron, has a fundamental property
associated with them called spin. (Actual “spin” of the particles has not been directly observed
but is used to model the property.) Electron spin, for purposes of this thesis, will be ignored.
The proton also has charge associated with it, and combined with its spin around its axis,
produces a current loop, also about the same axis. This current loop produces a net magnetic
field and can interact with external magnetic fields. The graphic of Figure 6 shows a single
proton spinning around its central axis.
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Figure 6.

Spinning Proton

Precession
Precession is a description of the circular motion of the rotation axis of a spinning object
subjected to an external force, that external force applying torque to axis of the spinning object.14
In the case of a spinning toy top, the angular velocity of the particles comprising the
rotating wheel (induced by the force of spinning the top) and the angular velocity of the applied
torque to the axis of rotation (induced by the earth’s gravity acting on the particles in the top’s
rotating wheel, combine to precess the toy top about a precessional axis. The angular motion of
the axis of spin is named precession, and describes a cone centered on the precessional axis.
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By eliminating all the friction and thermal loss components of the spinning wheel and
eliminating any variations in the external gravitational field, the spinning top would precess
about its precessional axis indefinitely. If the external gravitational field is removed, the top
would spin around its axis with no precession (the spin axis and precessional axis being
coincident). Frictional losses and thermal losses eventually cause the spinning top to stop
spinning and fall over.
Similarly, the spinning proton of the hydrogen atom, which has charge, and creates a
current loop, precesses about an axis under the influence of an external force, in this case the
bore coil’s magnetic field. Unlike the precessing toy top, or the gyroscope, the precessing
hydrogen nucleus does not fall over or stop spinning. Figure 7 depicts a single proton precessing,
the point of the spin axis transcribing a circle about the precessional axis. As shown in Figure 7,
the B field points upwards and the precession direction is clockwise viewed from above.
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Figure 7.

Precessing Proton

Larmour Frequency
The angular frequency of precessional spin of the hydrogen nucleus is a linear function of
the gyromagnetic ratio (a physical constant) of the hydrogen nucleus and the magnitude of the
externally applied magnetic field. The gyromagnetic ratio of the hydrogen nucleus, γ, and has a
value of 2.675 x 108 rad/s/T. Converting to Hertz, the equation becomes γ = 42.574 MHz/T.15
The Larmour equation equates the precessional frequency with the gyromagnetic ratio
and the magnitude of the externally applied magnetic field and is:
ω0 = γB0

(7)
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For an external magnetic field B0 of 1.5 T, the precessional frequency ω0 is 63.861 MHz.

Equilibrium Spin States
According to quantum mechanical principles, only two discrete spin states are available
for the hydrogen nucleus. The energy levels associated with these two quantum states are +½ħω0
and -½ħω0, where the Dirac constant ħ

h/2 and h is Planck’s constant (6.626176 x 10-34 kg

m2/s).16 The spin quanta numbers, -½ and +½ are associated with spins parallel to the external
magnetic field and anti-parallel to the external magnetic field, respectively. The spin quanta
number parallel to the external magnetic field is the lower of the two energy levels. Subtracting
the two, it is noted that the quantum energy difference is exactly ħω0.
Additional energy sources for hydrogen nuclei include the average thermal energy of the
surroundings indicated by kT, where k is Boltzmann’s constant (1.380650 x 10-23 kg m2/s2 K)17,
and T is the temperature in degrees Kelvin. It is noted that the thermal energy of the system is
much greater, millions of times larger, than the quantum energy differences between the two spin
states.
If the two energy values of the spinning hydrogen nuclei are compared, that is quantum
energy and thermal energy, in the form of a fraction, the “spin excess” is obtained as follows:

spin excess

N ħω0/2kT
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(8)

where N is the total number of spins present in a sample (N = 2 for hydrogen). Combining the
equations, the spin excess is:
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spin excess

N ħ γB0/2kT
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(9)

With an external magnetic field of 1.5 T the spin excess becomes:

spin excess

[2  (6.626068 x 10-34 kg  m2  s-1)  (2.675 x 108 rad  Tesla  s-1)  1.5 Tesla] / [2 

(1.380650 x 10-23 kg  m2  s-2  K)  300 ºK]

spin excess

(10)

10.2 x 10-6

(11)

This fraction indicates that there are approximately 10 extra hydrogen nuclei spinning
parallel to the external magnetic field for every million hydrogen nuclei. This exceedingly small
fraction is multiplied by the fact that there are Avogadro numbers of hydrogen atoms in the
volume being scanned.
The molecular mass of hydrogen is 1.00794 grams/mole and the molecular mass of
oxygen is 15.9949 grams/mole, making the mass of water approximately 18.01 grams/mole.20
The mass of water is also approximately 0.9982 grams/cm3 at 20 ºC. Therefore the number of
molecules of water in a cubic centimeter is approximately 0.055 moles/cm3. Assuming that the
MRI can detect volumes as little as one-eighth of a cubic millimeter, and there are 8000 “voxels”
in a cubic centimeter, then there are 6.928 x 10-6 moles of water molecules in a single voxel. To
determine the number of hydrogen nuclei in the voxel, the number of moles of water are
multiplied by Avogadro’s number and again multiplied by two (there are two hydrogen atoms in
each molecule of water). The result is approximately 8.34 x 1018 hydrogen nuclei in a voxel.
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Further multiplication of the hydrogen spin excess by the number of nuclei results in
approximately 8.52 x 1013 hydrogen nuclei that can be measured.

System Magnetization
The average proton magnetic dipole moment M0 is defined as:

M0 =

where

0

0

γ0 ħ2 B0 / 4 k T

(12)

is defined as the proton unit density or “spin density.” The magnetic field produced by

the excess spin magnetic dipole moment M0 is detected by applying a RF pulse tuned to the
Larmour frequency. The resonance of this RF pulse with the precessing proton ensures that the
precessing proton is “pushed” over in a continuous and synchronized fashion. Figure 8 depicts a
proton precessing at the Larmour frequency along a flat circular trajectory.
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Figure 8.

Flat Precession Proton

This is important to consider when the gradient coil fields are superimposed to localize
the resonance. An RF pulse that is capable of pushing the precessing proton all the way over by
90 degrees (from the z plane into the x-y plane) is called a /2-pulse. This hydrogen nucleus,
now spinning in the x-y plane at the Larmour frequency, produces a time-varying magnetic flux
that is coupled to a receiver coil and produces a measurable electromotive force in the receive
coil.
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Bore Coil Design

Bore Coil Shape
The MRI bore magnet is generally designed in a solenoid shape with varying designs of
shim coils to produce the most homogenous magnetic field possible, usually to within 1 ppm.

Magnetic Field Intensity
The magnetic field intensity is primarily based on the magnetic properties of the atoms of
interest and a trade-off between various physical properties of the magnet itself, such a size,
weight, power, cooling, cost, etc. However, a significant consideration for designing the bore
magnet is the increase in signal-to-noise (SNR) ratio as the field strength increases.

Gradient Coil Design

Gradient Coil Shape
The MRI gradient coils come in two varieties. The axial gradient coil, which varies the
magnetic field along the z-axis (head to foot), consists of an arrangement of Helmholz coils
placed on either end of the bore field.21
The gradient coils that vary the magnetic field along the sagittal and coronal directions
are much more complex. They take the shape of a “saddle” similar to the beam forming coils
found on CRT tubes, and are called “Golay coils.”22
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Magnetic Field Intensity
The magnetic field strength of the gradient coils is not as important as the uniformity of
the gradient field. The uniformity does not necessarily imply linearity; rather, as long as there are
no points within the B field that have the same values, a Fourier transform can be constructed.
Knowledge of the Fourier transform and the magnetic field can then be related to position and
frequency information to create a faithful image of the subject. However, linearity is a design
goal.
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CHAPTER FIVE: MRI INDUCED EDDY CURRENTS
The eddy currents produced by an MRI system are far too complex to be completely
described within the scope of a single thesis. In fact, the eddy currents produced by the
simulation of a single non-optimized MRI gradient coil and a first-order bore coil quickly
becomes too complex for a thesis. Therefore, only a few selected geometries and their results
will be modeled.
Given a simple experiment using a rare-earth magnet and a thin sheet of copper, and if
the magnet is dragged over the copper, the interaction between the magnet and the eddy currents
produced in the copper can be easily observed. What is not obvious is the interaction between the
eddy current and other magnetic fields. For example, the eddy current produced by the rare-earth
magnet reacts with the magnetic field of the earth, but the interaction is too small to observe
relative to the much larger interaction between the magnet and the eddy current it produces.
In order to better understand the graphs and graphics presented in this thesis, it is required
to establish a coordinate system and an understanding of the directions of rotation, currents, and
torques to be described. It is also important to clearly establish the cause and effect relationship
between the various inducing forces and induced results. Essentially, it needs to be determined
what is creating the phenomena and what is reacting with the phenomena.
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Figure 9.

Coordinate Geometry

The coordinate system that is used throughout this thesis, as shown in Figure 9, follows
the established coordinate system of a typical MRI system with the x-axis and the sagittal
directions being coincident. The y-axis is coincident with the coronal direction, and the z-axis is
coincident with the axial direction.
It has already been established that a static magnetic field cannot produce an eddy current
if the conductor is stationary. Therefore, since the materials modeled in this thesis are not
moving, and the bore field is static, the only item left to produce an eddy current is the gradient
coil. Therefore, an established eddy current within the scope of this thesis must be produced by
the gradient coil.
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The gradient coil is programmed to produce a sinusoidally excited B field that points
towards the negative y axis. In conjunction with the static B field produced by the bore coil, the
combination of the two fields produces a resultant field by superposition that increases in the
positive y direction. This action actually “adds” to the B field of the bore at the positive coronal
location in the bore and subtracts from the B field at the negative coronal location in the bore,
giving a gradient along the coronal axis. Ignoring for a moment the bore field, it has already been
established that a changing magnetic field produces a current that would oppose the field that
created it.
Referring to the graphic of Figure 9, the gradient field alone produces a current that
circulates ideally along the conducting sheet as shown by the current vectors. Using the right
hand rule, and curling the fingers along the path of current, the thumb points upwards; opposite
that of the gradient field. If the gradient field were uniform across the conducting surface, only
the eddy current would be established and all components of the current, and their associated
forces, added together produce no net force on the conducting sheet.
Now, we introduce the bore field, pointing to the left, or towards the positive z-axis. It is
this field and the gradient established eddy currents that interact to produce torques on the
conducting sheet. Using the right hand rule once again, and pointing the fingers flat in the
direction of the current flow, and curling the fingers in the direction of the bore field, the thumb
points in the direction of the force applied to the conducting sheet at that point. Using the graphic
in Figure 9, the current on the right hand side of the sheet, pointing towards the negative x
direction, interacts with the bore field to produce an upwards force (positive y axis) on the sheet.
The circulating current on the left hand side of the sheet produces a downward force. The
resulting forces on opposite sides of the conducting sheet, also using the right hand rule (for
27

cross products), indicates that the torque applied in this instance points toward the positive xaxis.
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CHAPTER SIX: MRI SIMULATION
Reference Coil Design
Using Ampere’s Law to validate the Maxwell software for B field modeling, a solenoid is
arbitrarily designed with 100 turns of #18 AWG copper wire, with a diameter or 1.02362 mm,
and supplied with 1.0 A of current. Using Ampere’s Law for a solenoid:23

B0 =

and replacing

0ni0

=

B = ni =

(13)

0k,

where k = 1.0000004, we have:

0kni

(14)

B = [4 x 10-7 kg  m  A-2  s-2]  [1.0000004]  [100/102.362 x 10-3 m]  [1.0 A](15)

B = 1.23 x 10-3 kg  A  s-2 = 1.23 x 10-3 Tesla

29

(16)

Figure 10.

Reference Coil

The reference coil was designed as a solid cylinder with a diameter of 11.02362 mm and
a length of 102.362 mm. The coil was created by subtracting another solid cylinder with a
diameter of 10.00 mm and a length of 102.362 mm. Copper was assigned as the material and the
entire structure enclosed in a space with a minimum of 200% of the dimensions of the solenoid
and assigned “air” as the material property.
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Figure 11.

Reference Coil

The cylinder was sectioned and an excitation current of 100.0 Amps applied (Maxwell
uses Finite Element Analysis (FEA) and models a solenoid as a solid mass with the currents
“stranded” uniformly through the mass. Thus, 1.0 A is modeled for each simulated “strand” or
wire with a diameter of 1.02362 mm. The B-Field plot as shown in Figure 12 was obtained.
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Figure 12.

Reference Coil B-Field

As is indicated in Figure 12, the B field is very uniform in the central core. The coil was
further enhanced by modeling a polyline through the center, extending 10 mm beyond either end.
B field data values were then captured and plotted.
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Figure 13.

Axial B Field Plot

The horizontal axis of the plot in Figure 13 is the distance in millimeters beginning with
the endpoint of the polyline extending through the central axis of the reference coil. The vertical
axis of the plot is the magnitude of the B Field in Tesla. At approximately 20 mm (10 mm inside
the coil), the B Field magnitude indicated is very close to the 1.23 x 10-3 Tesla calculated
previously and remains uniform through the center of the coil. Tabular data collected indicates
the maximum value to be 1.247 x 10-3 Tesla, thus substantiating the modeling methods to be
adequate for this investigation. Selected tabular data is presented in Table 1.
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Table 1 - Reference Solenoid Magnetic Field Strength
Distance

B-Field Magnitude

0.00000
(mm)
(Tesla)
10.0002
20.00040
18
30.0006
36
40.0008
54
50.0010
72
60.0013
90
70.0015
08
80.0017
26
90.0019
44
100.002
62
110.002
180
112.362
398
000
Torque Calculations

0.000224
0.000625
0.001037
0.001167
0.001221
0.001244
0.001247
0.001243
0.001230
0.001206
0.001099
0.000756
0.000622

In addition to the validation of Maxwell’s ability to generate B fields, it is also desired to
check the validity of the torque calculations. For this check, a well known configuration is used –
a square loop. The square loop used in this simulation is a 1 mm square cross section in a 100
mm x 100 mm square loop positioned at the epicenter of the bore field. The square loop is shown
in Figure 14.
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Figure 14.

Square Loop

The torque on a current loop is defined by the following equation:24

= B mt sin

(17)

Where B is the magnitude of the B field, mt is the magnitude of the magnetic moment,
and

is the angle between the B field vector and the magnetic moment vector. The magnetic

moment of a current loop is simply IA, where I is the current in the loop and A is the area of the
loop immersed in the B field. The resulting equation is:
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= IAB sin

(18)

The next step in the verification process involves calculating the theoretical value of the
torque applied to a 100 mm x 100 mm square loop with 1.0 Amp of current, immersed in a
uniform B field of 1.564 Tesla. The answer is 0.01564 Nm, or 1.564mNm.
Simulating the 100 mm x 100 mm square loop and establishing a 1.0 amp current as
shown in Figure 15, the setup for measuring the torque on the loop is completed.

Figure 15.

Loop Current
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As shown in Figure 15, the current vector in the upper portion of the loop points towards
the negative x-axis. The bore field points towards the positive z-axis, pointing directly out of the
page as shown in Figure 15. The cross product of the current and the B field will indicate that the
force on the upper segment of the loop points toward the positive y-axis. In this orientation there
is no net torque. However, if the loop were rotated to lie in the XZ plane, the torque would be
maximum and have the value as calculated above. A plot of the torques as a function of the
rotation angle of the current loop shown in Figure 16, where zero degrees of rotation indicates
the loop lies in the XZ plane is shown in Figure 15. The current loop is sequentially rotated in the
x-axis such that at 90 degrees of rotation the loop lies in the XY plane.

Figure 16.

Loop Current
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The table below (Table 2) shows a comparison of torque values calculated by Equation
(above) and as calculated by Maxwell.

Table 2 - Current Loop Torques
Rotation Angle
0
15
30
45
60
75
90

Theta

Equation (18)
(mNm)

90
75
60
45
30
15
0

15.64
15.10
13.54
11.06
7.82
4.05
0

Maxwell 3D
(mNm)
15.3307
14.8192
13.3276
10.9089
7.7653
4.0563
0.0857

Difference
(%)
2.0
1.8
1.6
1.4
0.7
0.1
0.0

As can be seen, the values correlate nicely with the theoretical values, thus exhibiting
sufficient validation to use Maxwell 3D for torque calculations. For this calculation, the gradient
coil current is turned off.

Bore Coil Design
For this simulated MRI bore magnet, the precise dimensions are unimportant as long as
the bore magnet forms a relatively long solenoid in order to obtain a uniform magnetic field.
Generally the bore dimensions of a typical MRI are approximately 36 inches in diameter and
also approximately 36 to 72 inches in length. This design uses a more convenient measurement
of 100 cm in diameter and 200 cm in length. To give the bore magnet solenoid sufficient mass
for stranded currents, the outer radius of the bore magnet is set at 200 cm.
Figure 17 shows the Maxwell 3D model of the simulated bore magnet with the sectional
plane into which Maxell 3D inserts current.
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Figure 17.

Bore Coil

Figure 18 shows the current and the graphic representation of stranding, the mathematical
equivalent to current flowing through multiple turns of wire found in a physical solenoid and in
an MRI bore magnet.
Using the right hand rule, and curling the fingers around the central axis of the bore, the
z-axis, the thumb points in the direction of positive magnetic field lines. Coincidentally, the legs
of a patient inserted into an MRI point in the positive z-axis.
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Figure 18.

Bore Coil Current

Figure 19 shows a field plot of the magnetic field intensity of the simulated MRI bore
magnet. The precise magnitude of the field is not relevant; rather the uniformity in the central
region of interest is important, but only for imaging purposes. For purposes of this thesis, precise
uniformity of less than 0.5 ppm across the entire region is unnecessary. As shown in the plot, a
uniformity of plus or minus 1000 Gauss is well within the area of interest for measuring torques
on various materials.
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Figure 19.

Bore Coil Field Intensity

In order to capture the numerical values of a field, reference geometry is required. In this
case a polyline is created along the central axis of the simulated MRI bore magnet and the field
intensity calculated along the line. A plot of the field intensity along the line is shown in Figure
20.
The area of interest consists of a small volume of space approximately 100mm on a side
located at the isocenter of the simulated MRI bore magnet. The z-dimensions of this volume
extend 50mm to each side of the 1-meter vertical axis of the plot.
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Figure 20.

Bore Coil Axis Field Plot

The exact equations used in Maxwell 3D, by Ansoft, Inc., are not published, but the field
solution verifies the following two Maxwell’s equations:

xH=J

(19)

B=0

(20)

with the following relationship:
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B=

0

(H + M)

(21)

where M is the permanent magnetization vector. Since there are no permanent magnets involved
in this thesis, and none in the simulations models, the equation reduces to:

B=

0

H

(22)

The Maxwell 3D solver considers the magnetic field strength vector, H, at all edges of
the mesh such that Ampere’s law holds on all contours of all tetrahedral faces. Nodal values for
each of the four vertices as well as all six mid-edge nodes are calculated to ensure a good
quadratic approximation inside each finite element. This method utilizes fewer computation
resources, excellent numerical stability, reducing cancellation errors, and the capability to
automatically connect iron regions.25

Gradient Coil Design
The design of the gradient coil follows the actual physical configuration of a typical MRI
system. There are three sets of gradient coils. The axial gradient coils are simple solenoid or
“Helmholtz” coils located at either end of the bore coil and concentric with the bore coil. One of
the coils, at the “head” end of the bore coil, is connected such that current flow in that coil
matches current flow in the bore coil, thus adding to the magnetic field strength. The other coil,
at the “foot” end of the bore coil, is connected such that the current circulates opposite that of the
bore coil, thus opposing the magnetic field of the bore. Since the bore field is upwards of 10,000
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to 15,000 times stronger than the gradient fields, the gradient fields simply add and subtract,
respectively, from the bore field and create an axial gradient that gets smaller as a function of
increasing z dimension. Since the configuration of the axial gradient coils is simply “another”
solenoid, they were not as interesting as the coronal and sagittal coils.
The coronal and sagittal coils consist each of a set of four “saddle coils” also know as
“Golay coils” oriented and connected such that their fields contribute and detract from the bore
field along the x and y axes. Using the graphic of Figure 22, and the right hand rule, current flow
in the section of the gradient coil near the top of the bore coil, at the “foot” end of the bore coil,
pointed towards the negative x-axis, will supplement the field of the bore. In the gradient coil at
the bottom of the bore coil, also at the “foot” end of the bore coil, with current connected in such
a way that it flows towards the positive x-axis, will detract from the bore field. Using the same
analogy with the coils at the “head” end of the bore coil, one can develop an overall supplement
to the field at the top of the bore and a detraction at the bottom of the bore for a gradient along
the y-axis, greater at the positive y-axis, and linearly decreasing at the negative y-axis extents of
the bore. The linear sections of the gradient coils cancel each other out, and the other looped
sections are placed sufficiently far from the bore that their fields contribute little to the bore
gradient.
Another set of four coils, rotated 90 degrees with respect to the coronal coils, constitute
the sagittal coils. For purposes of this thesis, it is not necessary to overly complicate the analysis
with the addition of the axial and sagittal coil sets. In fact, the addition of these coil sets will
overly complicate the eddy currents and seriously detract from the ability to capture meaningful
eddy current data.
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The gradient coils used are excited with a 100 Hz sinusoidal current waveform and the
data for two cycles of the waveform will be captured.

Figure 21.

Gradient Field Linearity

The data shown in Figure 21 is a normalized plot of the contribution of the gradient field
as a function of distance from the isocenter of the MRI bore. The data indicates that the field is
relatively linear with approximately 3.2 Gauss per centimeter gradient at maximum amplitude.
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Simulated MRI Design
The simulated MRI is designed using a composite of the simulated bore and the
simulated gradient coils. Each gradient coil is separated from the bore by 1 mm and is otherwise
concentric with the exact same diameter. The completed simulated MRI is shown in Figure 22.

Figure 22.

MRI Simulator

Using the exact same current as developed in the bore coil simulation, with the field
direction in the positive z-axis, the MRI simulator is established with a static field intensity of
approximately 1.5 T field intensity at the isocenter. A graphic indicating the bore coil stranded
current flow is shown in Figure 23.
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Figure 23.

MRI Simulator Bore Current

As described above, the gradient coil at the top of the simulated MRI, at the “foot” end of
the bore coil, is excited with a 100 Hz sinusoidally varying stranded current. The graphic of
Figure 24 shows the section of the gradient coil where current is inserted and its direction.
Following this current through the gradient coil, it can be noted that current flow in the curved
section next to the bore coil points in the negative x-axis direction, thus supplementing the bore
field at the top of the bore.
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Figure 24.

MRI Simulator Gradient Coil #1 Current

A rainbow plot of the field intensity, with the bore field on and the gradient coils excited
with a 100 Hz sinusoidally varying current, producing a field gradient of approximately 3.2
Gauss per centimeter at the peak of the current sinusoid, is shown in Figure 25. The field plot is
shown for intensity on the YZ plane.
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Figure 25.

MRI Simulator B Field Intensity

A plot of the field intensity, along the z-axis, is shown in Figure 26. This plot
demonstrates that the overall shape of the axial field inside the bore, is unaffected by the addition
of the gradient coils (see Figure 26).
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Figure 26.

MRI Simulator Axial B Field

Using the bore coil and a single set of gradient coils, a very good approximation of a MRI
system is developed, as long as certain limitations are observed. The first limitation is that the
simulated MRI in no way is modeled to represent an actual MRI for purposes of field linearity
and precision intensity. Nor is it intended to model all possibilities for eddy currents under the
influence of the combination of axial, coronal, and sagittal fields with the addition of shim coils
and RF coils. Finally, the volume of interest is limited to a section of the simulated MRI bore
field that can reasonably used to approximate conditions found in an MRI for the purposes of this
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thesis. A colored strip, as shown in Figure 27, indicates the extent of the field that is of interest
along the y-axis of the simulated MRI system.

Figure 27.

MRI Simulator Coronal B Field

51

CHAPTER SEVEN: TEST VOLUMES
Now that the MRI simulator is established, a number of test volumes can be inserted and
analyzed to form a reference for developing eddy current reduction techniques. An infinite
variety of sizes and shapes of test volumes can be developed. It would be impractical to attempt
to analyze every possible shape. As is well known in solid modeling CAD programs, and indeed
in Maxwell 3D as well, almost every shape can be modeled using only a small subset of
geometric shapes, combined in various ways to create more complex shapes. Furthermore, only a
small subset of geometric shapes comprises the shapes found in electronic and mechanical
devices inserted into MRI fields. For this thesis, a wire, sheet, block, box, sphere, loop, and
minor variations will be used. More complex shapes and their effects are left for future work.

Wire Test Volume
The wire modeled for this test volume has dimensions of 100mm x 1mm x 1mm. It is
assumed that the torque differences between round wire and square wire for purposes of this
thesis are insignificant. The wire is situated with its volumetric center point coincident with the
central coordinates of the simulated MRI bore, namely coordinates (0,0,0). The long axis is
oriented along the x-axis of the simulated MRI. The graphic in Figure 28 shows the wire in the
bore with an orientation of 0 degrees.
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Figure 28.

Aluminum Wire

The materials chosen for the wire are Aluminum, Copper, Silver, Stainless Steel, and
Iron. Two cycles of 100 Hz AC gradient coil excitation are captured. These materials represent
those most commonly found in electronic equipment and mechanical fasteners, as well as a
representative material for higher conductivity, silver, and a ferromagnetic material, iron.
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Figure 29.

Aluminum Wire – B Field vs. Time

The graph in Figure 29 shows the variation in the magnitude of the magnetic field
measured in Tesla at the simulated MRI central volume vs. time in milliseconds for four rotation
angles of aluminum wire around the simulated MRI z-axis, with counterclockwise rotation being
positive with the z-axis pointing directly at the viewer. As the wire is rotated, variations in the
eddy current interactions distort the field, causing the localized field strength to vary. As the wire
is rotated, the localized field strength increases until the wire is vertical in the field. The
differences in magnetic field intensity, however, contribute little to the overall torques applied to
the wires. The primary effect is caused by the gradient coil generated eddy current interacting
with the bore static field.

54

Figure 30.

Aluminum Wire – X-Axis Torque vs. Time

The graph in Figure 30 illustrates the variation in torque strength as a function of rotation
angle with the vertical axis indicating x-axis torque, in nano-Newton meters vs. time. The
important point to note is the fact that the torque in the x-axis is decreasing as the rotation angle
increases. Using the cross product of the magnetic field vectors and current vectors, it is clear
that the eddy current is circulating around the x-axis in a clockwise fashion as viewed from the
positive x-axis.
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Figure 31.

Aluminum Wire – Y-Axis Torque vs. Time

The graph in Figure 31 also shows the magnitude of the torque vs. time, but in this case
the torque is around the y-axis and increases as the rotation angle increases. The cross product
between the bore field and the eddy current indicates once again that the eddy current circulates
clockwise around the y-axis as viewed from the positive y-axis.
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Figure 32.

Aluminum Wire – Z-Axis Torque vs. Time

The graph of Figure 32 shows the magnitude of the torque around the z-axis as a function
of the rotation angle of the wire, with the magnitude of the torque in nano-Newton meters in the
vertical axis and time in the horizontal axis. Note, however, that the scale in the z-axis graph
shows torques less than 4nNm in all cases, where the torques in the x and y axes are several
hundred times larger.
Based on the magnitudes of the torques, and the relative increases and decreases as a
function of rotation angle, it is conclusive that the eddy current acts with the bore field and the
gradient field that produced the eddy current has little effect on the torque. It is unlikely that any
definitive data can be derived from the z-axis torques due to the tolerances of the Maxell analysis

57

being of similar magnitude, and the complex interactions between gradient coil induced eddy
currents and the much larger bore field.

Figure 33.

Wire – X-Axis Torque vs. Material

Knowing that the x-axis torque of aluminum wire as a baseline, and establishing that the
torque is greatest in the x-axis when the wire is aligned with the x-axis, a comparison of the
torque is made for several different materials.
The graph in Figure 33 shows the magnitude of the x-axis torque vs. time as a function of
materials. The “00” in the title indicates that the materials are positioned in the 0-degree rotation
angle. Copper and Silver have a conductivity slightly less than twice that of aluminum, allowing
eddy currents to be established with correspondingly greater magnitude, resulting in an increased
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torque. Stainless Steel, however, has a conductivity approximately 40 times smaller than
aluminum, and thus cannot carry any eddy current as well as aluminum, copper, and silver. A
table of conductivities and the simulation values used by Maxwell 3D is shown in Table 3.

Table 3 - Material Conductivity
Material
Aluminum
Copper
Silver
304
Iron
Stainless Steel

Resistivity26
(micro-ohm-cm)

Conductivity
(Siemens/m)

Simulation Value
(Siemens/m)

2.6548
1.6730
1.59
68.97
9.71

37,667,620.
38,000,000
59,772,863.
58,000,000
91
62,893,081.
61,000,000
12
1,449,905.7
1,100,000
76
10,298,661.
10,300,000
5
17
Iron was purposefully left out of the graph of Figure 33. The metals listed in Figure 33

are non-ferrous metals with a magnetic permeability of approximately 1.0. The magnetic relative
permeability of a substance is the ratio of the magnetic inductance in the substance to the
magnetic field to which it is exposed. The permeability of free space is exactly 4 x 10-7 N A-2.
By definition, the relative permeability of free space is unity. This means that the magnetic field
is not influenced by these materials much more or less than air or free space influences the field.
However, iron has a magnetic permeability of 4000, meaning that iron reacts with the magnetic
field intensely compared to aluminum, copper, silver, and stainless steel.
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Table 4 - Material Magnetic Permeability27
Material

Relative Permeability

Vacuum
Air
Aluminum
Copper
Silver
304
Stainless
Iron

1.0
1.0000004
1.000021
0.999991
0.99998
1.0
4,000

Steel
Thus, the eddy current effects in iron (and other magnetic materials) will be insignificant
compared to the material itself. Table 4 lists the relative permeabilities of selected materials, as
used by Maxwell 3D.

Figure 34.

Wire – X-Axis Torque vs. Material

60

The graph in Figure 34 shows the x-axis torque of the iron wire with the vertical axis
showing torque and the horizontal axis showing time. (The “00” in the title indicates that the
materials are positioned in the 0-degree rotation angle.) Although iron still reacts sinusoidally
with the time-varying gradient coil, this influence is based on the sinusoidal magnetization of the
iron and its coincidental attempt to line up with the bore field. The magnitude of the average
torque, roughly 0.49 Nm, indicates that approximately 0.1 pounds of force is exerted on the end
of the wire, or approximately 1.7 ounces of force.

Sheet Test Volume
The torques experienced on a sheet of conductive material can be thought of as a
summation of the torques on individual wire segments comprising a sheet. When immersed in a
uniform magnetic field, and acted upon uniformly, the torques experienced by a single
differential element of the sheet, a wire, is summed. But, this analogy extends beyond just the
simple summation of the torque effects. A sheet of conductive material contains many more
conductive paths than a wire, and thus allows eddy currents to be established more efficiently
than in a wire. Comparison of the magnitudes of the torques experienced in a wire (nNm) and
those in sheets (mNm) indicate many orders of magnitude greater eddy currents in a sheet as
opposed to a wire. However, torque components experienced in the wire that is in the plane of
the sheet, and those that are rotational, are cancelled. Only the excess and tangential components
of torque are experienced.
The sheet modeled for this test volume has dimensions of 100mm x 1mm x 100mm. The
sheet is situated with its volumetric center point coincident with the central coordinates of the
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simulated MRI bore with its long dimensions in the x and z directions. The graphic in Figure 35
shows the sheet in the bore with an orientation of 0 degrees.

Figure 35.

Aluminum Sheet

The materials chosen for the sheets are Aluminum and Copper. Two cycles of 100 Hz AC
gradient coil excitation are captured. When capturing data for many of the test volumes, in order
to reduce simulation processing, only significant points of interest along the sinusoid are
captured. To demonstrate that the data is indeed sinusoidal in nature, a more detailed data
capture algorithm was designed and the data captured for the sheet analysis. Subsequent
materials and geometries will return to analysis of only certain points along the sinusoidal
excitation in the MRI bore.
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Figure 36.

Aluminum Sheet – B Field vs. Time

In the plot of Figure 36, the magnetic field was plotted as a function of the rotation angle
of the aluminum sheet. Each plot is coincident (within the tolerance of this simulation),
indicating that the non-ferrous material, aluminum, has no significant effect on the magnetic
field itself.
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Figure 37.

Aluminum Sheet – 30 degree rotation

The graphic of Figure 37 shows the view looking into the positive z-axis (z-axis points
out of the page towards the viewer) with the positive x-axis to the right and the positive y-axis
pointing upwards. The angle of rotation is zero degrees when the sheet is flat (coincident with
the XZ plane). The angle increases in the counter-clockwise direction. The sheet is shown in the
30 degree orientation.

64

Figure 38.

Aluminum Sheet – X-Axis Torque vs. Time

The plot in Figure 38 shows the magnitude of the torque experienced along the x-axis,
measured in milli-Newton-meters. The horizontal axis indicates time in milliseconds and the
vertical axis indicates torque. The four plots, each indicating a different rotational orientation in
the XY plane, demonstrates that the x-axis torque is significant when the sheet is oriented flat
(flat relative to a patient lying in the MRI bore), and decreases as the sheet is rotated to a vertical
orientation.
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Figure 39.

Aluminum Sheet – Y-Axis Torque vs. Time

Figure 39 shows the torque on the aluminum sheet in the y-axis. The horizontal axis of
the plot is time in milliseconds and the vertical axis indicates torque, in milli-Newton-meters. In
contrast to the torque in the x-axis, the torque experienced by the sheet in the y-axis is minimal at
zero degrees rotation and increases as the rotational angle increases. It is interesting to note the
phase reversal of the torque at 90 degrees of rotation. This phase reversal would indicate that a
sheet that moves between the orientation just less than vertical, say 89 degrees, and an
orientation just past the vertical, say 91 degrees, will experience the maximum torque in one
direction and then in the other. Thus, the phase reversal supports the contention that vibrations
occur in equipment containing metal sheets placed within the MRI bore.
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Figure 40.

Aluminum Sheet – Z-Axis Torque vs. Time

The plot of Figure 40 shows the z-axis torque of the aluminum sheet as it is rotated in the
XY plane. The horizontal axis depicts time in milliseconds and the vertical axis indicates torque
in milli-Newton-meters. An examination of the plots, and their various phase shifts, indicate a
complex combination of torque components summing and cancelling to produce resultants that
are not simple reflections of the excitation fields. Comparing the magnitudes of the forces, it is
clear that the x and y torques are two to three orders of magnitude greater than the torque in the
z-axis. Thus, the z-axis torque is relatively insignificant.
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Figure 41.

Sheet – X-Axis Torque vs. Material

The plot shown in Figure 41 demonstrates a similar artifact as found in the comparison of
materials in the wire test volume – conductivity contributes to the torque. As shown in the plot,
copper experiences a slightly greater torque, due to the greater ability to conduct current, and the
resulting larger interaction with the static bore field. (The “00” in the title indicates that the
materials are positioned in the 0-degree rotation angle.) It is assumed that more conductive
materials will exhibit greater interaction, such as silver, and less conductive materials will
exhibit less interaction, such as stainless steel.
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Block Test Volume
The torques experienced on a block of conductive material can also be extended in a
similar fashion as the wire is to the sheet. A block of material is a summation of sheets.
Correspondingly, the magnitudes of the torques increase as the conductive volume, and thus the
conductive paths, increases.

Figure 42.

Aluminum Block – X-Axis Torque vs. Time

The plot in Figure 42 shows the torque experienced by a block of aluminum that is
100mm on a side. The magnitude is approximately one order of magnitude greater than a sheet.
The horizontal axis of the plot indicates time in milliseconds and the vertical axis indicates
torque in milli-Newton-meters. Each of three angles of rotation in the XY plane is shown. Due to
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symmetry of the block, the 90 degree rotation angle is identical to the zero degree rotation angle,
and therefore, is not indicated. The plot indicates that the x-axis torque, where the conducting
volume extends greatly in all three dimensions, is relatively unaffected by orientation. This
indicates that there is a preferred current path for eddy currents and the primary contributor is in
the x-axis.

Figure 43.

Aluminum Block – Y-Axis Torque vs. Time

The plot shown in Figure 43 shows the torque experienced by the aluminum block in the
y-axis. The horizontal axis indicates time in milliseconds and the vertical axis indicates torque in
milli-Newton-meters.
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This plot indicates that the interaction of the gradient coil induced eddy current and the
bore field are more dependent when torque in the y axis is involved. As the block is rotated, the
magnitude of the y-axis torque increases. Similarly, the 90-degree rotation angle is identical to
the 0-degree rotation angle.

Figure 44.

Aluminum Block – Z-Axis Torque vs. Time

In a similar fashion to all previous test volumes, and due to the orientation of the bore
field and the selected gradient field, the torque in the z axis remains unimportant. It is interesting
to note the phase reversal between 0-degrees and 30-degrees, and yet another one between 30degrees and 60-degrees. These reversals are indicative of the complex nature of the induced eddy
currents due to only one gradient coil. The addition of two more gradient coils as well as various
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shim coils and RF coils will quickly create eddy currents much more complex than is the subject
of this thesis.

Figure 45.

Block – X-Axis Torque vs. Material

The graph in Figure 45 demonstrates that the conductivity of the material still remains of
importance, but as the volume of the material increases, the contribution of torque due to
additional conductivity decreases as compared to the addition of a multitude of additional
conduction paths. (The “00” in the title indicates that the materials are positioned in the 0-degree
rotation angle.) In Figure 45, the horizontal axis depicts time measured in milliseconds and
torque measured in milli-Newton-meters along the vertical axis. The materials aluminum and
copper are compared.
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Box Test Volume
The box test volume was modeled in Maxwell 3D as a solid block with a slightly smaller
solid block, appropriately positioned, and then subtracted from the larger block. The remaining
structure is a box of material with external dimensions of 100 mm on a side and a material
thickness of 1mm. The box represents the most prevalent structure found in devices inserted into
MRI bores.

Figure 46.

Aluminum Box – X-Axis Torque vs. Time

Based on the graph of Figure 46, it appears that the lack of a central volume disrupts the
eddy current paths and is essentially a summation of torques from sheets in orthogonal planes.
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This makes the torques on the unit much more complex and variable. At some points the torques
are relatively small, at others much larger, contributing to the overall hypothesis that hollow
conducting volumes placed in MRI bores experience widely variable vibrations.

Figure 47.

Aluminum Box – Y-Axis Torque vs. Time

Due to the geometry of the bore field and the gradient coil, the y-axis torque is a complex
summation of individual torques on sheets in various orientations and has preferred orientation
between 30 degrees and 60 degrees to conduct eddy currents that interact with the bore field.
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Figure 48.

Aluminum Box – Z-Axis Torque vs. Time

Surprisingly, the eddy currents sum in a fashion to create a large z-axis torque as given in
Figure 48.

Torus Test Volume
The torus is modeled to determine if any significant eddy current effects can be
determined on electrical or mechanical items with circular, torroidal, or cylindrical shapes, such
as knobs, indicator bezels, and dials. Hopefully an electronic designer will not be faced with
eddy currents established inside a torroidal transformer or coil – it will be shielded or excluded
from the equipment placed in the bore.
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Figure 49.

Aluminum Torus

It already has been hypothesized that if eddy currents are reduced, torques will be
reduced. It is also surmised that differences in materials produce differences in torque as a
function of conductivity, so analysis of the torus is limited to aluminum for material, 100 mm
major radius for shape, and the rotational angle about the z-axis. The minor diameter is 1.0 mm.
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Figure 50.

Aluminum Torus – X-Axis Torque vs. Time

Using the right hand rule as established earlier, it is clear that the torus behaves precisely
as expected, with a maximum torque when the torus lies completely in the XZ plane and
diminishing to zero when the torus is rotated to the YZ plane. In the XZ plane, the torus contains
segments that have a maximum cross product between the current and the bore field, producing
maximum force on that segment, and thus maximum torque in the x-axis. As the torus is rotated
into the YZ plane, the cross products diminish to zero.

77

Figure 51.

Aluminum Torus – Y-Axis Torque vs. Time

As the torus lies in the XZ plane, the current path is essentially a loop around which eddy
currents may flow. All other dimensional characteristics and conductive paths are small in
comparison. The graph in Figure 51 demonstrates that no torques in the y-axis exist with any
meaning. As the torus is rotated towards the YZ axis, geometries and conduction paths are
presented that allow significant cross products producing torque forces in the y-axis. However,
as the angle increases to the vertical position, in the YZ plane, the y-axis torques minimize once
again. The phase reversal is probably due to the software calculating the torque as 90 degrees
belonging to the second quadrant.
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Figure 52.

Aluminum Torus – Z-Axis Torque vs. Time

The z-axis torque in Figure 52 is essentially non-existent, with the components shown in
the graph of Figure 52 representing imprecision in the calculations of individual tetrahera of the
torus mesh.

Sphere Test Volume
A sphere of conducting material is modeled in a similar fashion as the box. A solid
sphere of material is modeled and a slightly smaller volume is subtracted. The remaining
structure, a conducting spherical shell of material, is then placed in the simulated MRI for
analysis.
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The sphere is probably the least likely structure to be found in typical equipment placed
in MRI bores, but is modeled here as a reference geometry to gain insight into the reaction of this
conducting geometry with the magnetic field. Since the symmetry of the sphere precludes
differences in rotational orientation, the radius of the sphere is altered to extract any significant
data.

Figure 53.

Aluminum Sphere – 50 mm Radius

The sphere shown in Figure 53 depicts the model of the 50 mm radius sphere with the
mesh plotted. The internal radius of 49 mm leaves a material thickness of 1 mm and the mesh
thus subdivides the material into several thousand tetrahedral elements from which the finite
element analysis is performed.
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Figure 54.

Aluminum Sphere – 200mm Radius

Figure 54 shows the 200 mm sphere at the isocenter of the simulated MRI bore. The 12sided cylinder of the bore dummy mesh as well as an additional dummy mesh just outside the
200 mm volume of interest, are clearly shown.
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Figure 55.

Aluminum Sphere – X-Axis Torque vs. Time

Based on the graph it is probably correct to assume that a sphere must attain a certain
minimum size, probably dependent on the magnitude of the field, in order to sustain eddy
currents capable of interacting with the bore field. In the graph of Figure 55, the 50 mm and 100
mm spheres show no significant torque while the 200 mm sphere indicates only about 1.2 mNm
or torque, significantly less than previous test volumes. Although the sphere has little usefulness
as an object within the MRI bore, its configuration contributes the least to torque.
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Figure 56.

Aluminum Sphere – Y-Axis Torque vs. Time

The y-axis torque shown in Figure 56 for the 200 mm sphere is approximately 3 times
smaller than the x-axis torque, indicating that the eddy currents primarily circulate in the XZ
planes of the sphere. The eddy currents, however, produce approximately equal torque in the
negative z-axis (Figure 57), also supporting the current flow in the XZ plane, and indicating a
counter-clockwise rotation as viewed from the positive y-axis (looking along the negative yaxis).
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Figure 57.

Aluminum Sphere – Z-Axis Torque vs. Time

As a check to verify the torques are produced by the interaction of the gradient coil
induced eddy current and the static bore field, and to determine the extent of the contribution of
torque from the gradient field itself, the bore field was turned off and the simulation run again.
As shown in the graph of Figure 58, the torque on the 200 mm sphere was plotted as a function
of time. The x-axis torque is approximately 27 times less than that produced by the interaction of
the bore field and the gradient coil induced eddy current. It is interesting to note that the
interaction of the sphere and the gradient coil self induced eddy current tend to create a second
harmonic, thus validating the slightly distorted graphs of previous test volumes.
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Figure 58.

Aluminum Sphere – X-Axis Torque vs. Time

Twin Loop Test Volume
The Twin Loop represents a slightly more complex shape that may be found in electronic
or mechanical devices placed in an MRI bore, such as the bobbin of a standard transformer,
mounting hardware used to attach larger items (screws used to attach a mechanical fixture), or a
mechanical fastener used to hold a patient’s sample line or cable.
The Twin Loop in this experiment was devices primarily to determine if it was
reasonably possible to determine or predict a specific path for current flow.
As oriented in the XZ plane (zero degrees angular rotation), the Twin Loop presents two
major conducting circuits for eddy currents. Using the right hand rule, each of the two loops will
conduct current in a counter-clockwise direction as viewed from above (looking in the same
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direction as the negative y-axis). This will cause current in the central section of the loop to
contain current paths that, if summed together, cancel each other out.

Figure 59.

Twin Loop

Figure 59 shows a top view (looking in the direction of the negative y-axis) of the Twin
Loop. The arrow running down the center of the central leg of the Twin Loop is the positive zaxis. The element mesh is overlaid on the graphic indicating each of the several thousand
tetrahedral comprising the Twin Loop.

86

Figure 60.

Aluminum Twin Loop – X-Axis Torque vs. Time

The graph of Figure 60 shows the torque on the Twin Loop along the x-axis of the
simulated MRI system. The horizontal axis of the graph indicates time in milliseconds and the
vertical axis indicates torque in milli-Newton-meters. With the premise that when laid along the
XZ plane, the current in the central section of the material will essentially cancel also predicts
that the torque also cancels. The graph indicates that this is true. However, as the simulation
changes from zero to 1.0 milliseconds, the torque jumps dramatically to a near-maximum value.
(The simulation at t = 0 has no previous model upon which to base its calculations, thus jumping
from zero to maximum. The difference between 10 milliseconds and 11 milliseconds more
accurately reflects the change in eddy current and torque calculations.)
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Figure 61.

Aluminum Twin Loop – Y-Axis Torque vs. Time

The graph of Figure 61 represents the torque along the y-axis for various rotational angles
of the Twin Loop as a function of time. The horizontal axis indicates time in milliseconds and
the vertical axis indicates torque in milli-Newton-meters. The torques at zero and 30 degrees of
angular rotation show little y-axis torque whereas the 60 and 90 degree rotations show
significantly larger torque values.
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Figure 62.

Aluminum Twin Loop – Z-Axis Torque vs. Time

Figure 62 shows a plot of the z-axis torque for various rotational angles of the Twin Loop
as a function of time. The horizontal axis indicates time in milliseconds and the vertical axis
indicates torque in milli-Newton-meters. The z-axis torque is hundreds to thousands of times
smaller than the other two axes, but shows the complex interaction of the eddy currents in the
small dimensions of the Twin Loop. This plot shows that many times the eddy current adds,
subtracts, and reverses itself within the structure.
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Figure 63.

Aluminum Twin Loop – Current vs. Time

A plot of the current as a function of time, for the various angular rotations of the Twin
loop is shown in Figure 63. Time is indicated for the horizontal axis in milliseconds and the
vertical axis indicates current in amps. Maximum current flow through the central section of the
Twin Loop is indicated for the 90 degree rotational orientation with approximately 160
milliamps at peak excitation.
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Figure 64.

Aluminum Twin Loop – Current vs. Rotation Angle

One goal established prior to simulation was to determine if there was a point at which
current flow could be stopped in a conducting path and what the conditions were to prevent this
current flow.
In the simulation, a section was created in the exact center of the central leg of the Twin
Loop. The section was required in order to establish an element to which an equation could be
applied that will calculate the current through that section. The equation is:

I=

s

J  n ds

(23)
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This equation is the surface integral (of the section) of the dot product of the current
vector through the section and the vector normal to the section. In essence, this equation sums up
all the contributing currents through each mathematical element crossing the surface, whether in
one direction or the other, which are normal to the section. This equation is created in Maxwell
3D using the field calculator and is described in the addendum.
As shown in the graph of Figure 64, the maximum current is shown as a function of
angular rotation and demonstrates that the current flow in the central leg of the Twin Loop stops
when the Twin Loop is rotated to approximately 40 degrees. Not surprisingly, eddy currents are
highly dependent on physical orientation with relation to the inducing field.
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CHAPTER EIGHT: EDDY CURRENT REDUCTION TECHNIQUES
Round Holes Technique
From a manufacturing point of view, a perforated sheet is relatively easy to manufacture.
A solid sheet of material is passed through a punch and die set that perforates the sheet, one hole
at a time, one row at a time, or several rows at a time, eventually filling the sheet with holes.
Thus, the availability of materials with round perforations allows electronic or mechanical
devices and other structures to be easily fabricated for use in MRI systems.
The perforated sheet modeled here consists of a 100 mm x 1 mm x 100 mm aluminum
sheet with twenty five 5 mm radius holes placed uniformly across the surface. Figure 65 shows a
top down view of the aluminum sheet.

Figure 65.

Aluminum Sheet – Round Perforations
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The graph of Figure 66 shows the x-axis torque on the sheet as a function of time for
various angular rotations about the z-axis. Time is indicated along the horizontal axis in
milliseconds and torque in milli-Newton-meters is indicated for the vertical axis.
As with the solid sheet, the magnitudes of the x-axis torques (Figure 66) at 0-degrees of
angular rotation are maximum and decrease as the rotation angle increases towards 90 degrees.
However, unlike the solid sheet, a preferred orientation appears, in this case at 30 degrees, most
likely due to a conduction path that is more efficient in this orientation.

Figure 66.

Round Perforated Aluminum Sheet – X-Axis Torque vs. Time
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The y-axis torque also shows a preferred orientation, but with opposing direction. In the
graph of Figure 67, the horizontal axis indicates time in milliseconds with the vertical axis
indicating torque in the y-axis direction in milli-Newton-meters. For the 60 and 90 degree
orientation, the y-axis torque is almost non-existent. A positive y-axis torque exists at 0 degree
rotation while the 30 degree rotation exhibits maximum torque among these orientations.

Figure 67.

Round Perforated Aluminum Sheet – Y-Axis Torque vs. Time

The z-axis torque also exhibits a preferred orientation, but with much less force,
approximately one-tenth that of the y-axis. In this case all but the special 30-degree orinetation
exhibits practially no torque. In the plot of Figure 68, the horizontal axis represents time in
milliseconds with the z-axis torque in milli-Newton-meters indicated along the vertical axis.
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Figure 68.

Round Perforated Aluminum Sheet – Z-Axis Torque vs. Time

Square Holes Technique
Square hole perforations are also readily available in prefabricated sheets although the
manufacturing process is slightly more troublesome. The punch and dies sets for square holes
tend to dull quicker than round holes, especially at the corners, making share hole perforated
material slightly more expensive to purchase.
The perforated sheet modeled here consists of a 100 mm x 1 mm x 100 mm aluminum
sheet with twenty five 10 mm square holes, placed uniformly across the surface. Figure 69 shows
a graphic of the sheet with square holes as seen looking in the same direction as the negative yaxis. In this graphic the positive z-axis is pointing down.
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Figure 69.

Aluminum Sheet – Square Perforations

In the case of the sheet with square holes, the disruption pattern seems to have a better
behavior pattern than the sheet with round holes. It is hypothesized that the square holes disrupt
the eddy current flow in such a manner as compared to the sheet with round holes, that a special
preferred orientation is not established.
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Figure 70.

Square Perforated Aluminum Sheet – X-Axis Torque vs. Time

The graph in Figure 70 shows the x-axis torque for each of the four angular orientations
of the aluminum sheet with square holes. The horizontal axis indicates time in milliseconds and
the vertical axis indicates x-axis torque in milli-Newton-meters. For the zero degree orinetation
the x-axis torque is maximum, indicating that the circulating paths around each hole, and perhaps
groups of holes, contirbute to the overall torque of the sheet. As the sheet is rotated, however, the
circulating paths quickly are distrupted leaving only the small dimensions of the sheet for eddy
current circulation.
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Figure 71.

Round Perforated Aluminum Sheet – Y-Axis Torque vs. Time

The y-axis torque exhibits a slightly different pattern as shown in Figure 71. Almost no
torque in the positive y-axis is exhibited at zero degrees orientation. As the sheet is rotated the
torque peaks and diminishes to a point where eddy currents remain to produce y-axis torque in
the 90 degree orientation. Phase shifitng is an artifact of the second quadrant.
The z-axis torque is essentially non-existent, but definitely has a preferred orinetation –
zero degrees. The graph of Figure 72 shows the torque in the z-axis. The horizontal axis of the
graph indicates time in milliseconds and the vertical axis indicates torque in the positive z-axis in
milli-Newton-meters. The overall magnitude is approximately one hundred times smaller than
the y-axis and perhaps 50 times smaller than the x-axis.
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Figure 72.

Round Perforated Aluminum Sheet – Z-Axis Torque vs. Time

Other Techniques
It is natural to assume that eddy currents formed in a conducting sheet will, at least in the
ideal sense, circulate around the entire sheet. Therefore, any disruption in that circulation will
distort the current path and make it less able to interact with an external magnetic field.
Furthermore, the disruption may increase the current path and reduce the magnitude of the eddy
current, further reducing its ability to interact with an external magnetic field.

Configuration 1
Assuming that the ideal eddy current conduction path utilizes the entire conducting
volume of a conducting sheet, a disruption consisting of a single perforation should reduce the
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eddy current by increasing the path length, changing the conduction path, and thus reduce the
torque experienced on the sheet.

Figure 73.

Aluminum Sheet – Sheet01

The sheet configuration shown in Figure 73, named Sheet01, is a 100 mm x 1 mm x 100
mm aluminum sheet with a 20 mm x 20 mm square cutout located 10 mm from each of two
edges as shown.

Configuration 2
Another sheet configuration shown in Figure 74, named Sheet02, is also a 100 mm x 1
mm x 100 mm aluminum sheet with a 20 mm x 20 mm square cutout, but the cutout has been
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located at 20 mm from each of two edges. The cutout was moved to determine if perhaps the
eddy current path is more or less interrupted by the location of the cutout.

Figure 74.

Aluminum Sheet – Sheet02

Configuration 3
The cutout pattern is extended to include two cutouts, as shown in Figure 75, both 20 mm
x 20 mm, with one located 10 mm from the two edges as shown, and the second one located 10
mm from one edge, but separated from the first cutout by a gap of 10 mm. The sheet in Figure 75
is named Sheet03.
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Figure 75.

Aluminum Sheet – Sheet03

Configuration 4
The next pattern, named Sheet04, extends the pattern group by moving one of the cutouts
to the far side of the sheet, 10 mm from the opposite edge from the first cutout. The cutout
pattern is shown in Figure 76.
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Figure 76.

Aluminum Sheet – Sheet04

Configuration 5
Finally, Figure 77 shows a cutout pattern similar to that of the Twin Loop. In this case,
the primary objective is not to measure current in the central leg of the pattern, but to more
closely simulate a sheet of material that may have large dimension cutouts relative to the overall
dimensions of the sheet, that will closely approximately an enclosure with external cutouts, or a
belt buckle used as a mechanical strap to hold devices to a patient.
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Figure 77.

Aluminum Sheet – Sheet05

In the configuration named Sheet05, as shown in Figure 77, the cutouts are designed to
leave a band of material 10 mm in width around the perimeter of a 100 mm x 1 mm x 100 mm
aluminum sheet. A central band of material, also 10 mm in width runs down the exact center of
the pattern.
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Figure 78.

Perforated Aluminum Sheet – X-Axis Torque vs. Time

The graph of Figure 78 plots the x-axis torque experienced by each of the 5 sheets with
various hole locations. The horizontal axis is a plot of time in milliseconds and the vertical axis
is a plot of the magnitude of the x-axis torque measured in milli-Newton-meters. All sheets are
oriented in the 0-degree rotation position. It is assumed that axial rotation will produce similar
results as those in previous test volumes.
The plot of Sheet01 indicates that the eddy current has been reduced significantly from an
uncut sheet. The peak value of the uncut sheet is approximately 1000 mNm (1Nm), to
approximately 100 mNm (0.1Nm), a factor of 10. Additionally, a comparative phase reversal has
occurred indicating the the induced eddy current contributor has changed direction.
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The plot of Sheet02 indicates that the movement of the hole from the corner towards the
middle of the sheet has demonstrated that the eddy currents tends to circulate along the exterior
perimeter as demonstrated by the increased torque.
The plot of Sheet03 reinforces the edge based eddy current but also supports the
indication that the continual loss of conducting material contributes to the reduction in eddy
current magnitude, as is expected.
Sheet04 simply moves one of the cutouts and has little effect on the eddy current
contributing to the torque.
However, the plot of Sheet05 is significantly reduced, due in a greater extent to the
reduction in material as opposed to eddy current path lenghtening or path changes.

Figure 79.

Perforated Aluminum Sheet – Y-Axis Torque vs. Time
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As expected the y-axis torques are much less than those of the x-axis as shown in Figure
79.

Figure 80.

Perforated Aluminum Sheet – Z-Axis Torque vs. Time

In the case of materials with hole patterns, the z-axis torque (Figure 80) indicates that the
eddy current flow in the sheet as opposed to the thickness dimension.
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CHAPTER NINE: CONCLUSION
The data accumulated represents hundreds of man-hours tending to numerous simulations
using a dual Pentium-IV based laptop running Ansoft’s Maxwell 3D program. It is impossible to
view this many simulations and not get a subjective opinion of the results.
After collecting many megabytes of data, extracting the meaningful pieces for
presentation (without overwhelming the reader), plotting the data, and formatting the graphs for
visual clarity, it is impossible not to validate the correct assumptions and refute the incorrect
assumptions.
The major conclusions that can be drawn from this work are:
1. Eddy currents are established by changing magnetic fields.
2. Eddy currents will react most strongly with the strongest magnetic field – not
necessarily with the field that created it in the first place.
3. Better conductors produce larger eddy currents.
4. Path disruptions decrease eddy currents in two ways – change in direction and
increased path length.
5. Orientation contributes significantly to the eddy current effects.
6. Shape has less of a contribution to eddy currents than path length or disruption
pattern.
7. Ferromagnetic materials create other effects that dwarf eddy current effects.
Although there are a number of graphs with data that may not perfectly line up with
anticipated results, they are adequately explained with sufficient detail to be useful. Additional
causes of unruly data may include improper setups of the Maxwell software and complexities too
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small to be seen or recognized at the level of this thesis. Therefore, it is advised that the data
presented here is used in conjunction with sound engineering design practices, adequate testing
before deployment, and a small bit of skepticism.
The results of the work on this thesis leave many interesting areas for future work. The
work on this thesis also creates many additional questions to be answered. Future work includes:
1. Simulation of the sagittal and axial gradient coils to obtain eddy current data with
all possible inducing sources and compare with single source inducers (as is the
case with this thesis).
2. Simulation of the RF coils to incorporate the effects of higher frequency induced
eddy currents.
3. Simulation and addition of shim coils to create a more uniform bore field,
eliminating fringe effects.
4. Addition of frequency domain components to the simulation extending the tactile
frequency range into the audible frequency range and incorporating inertial
components of material mass.
5. Extending the range of shapes to more complex and varied combinations,
including actual configurations in use today.
6. More detailed mapping of eddy current paths in response to one, two, or three
gradient coils as well as RF coils.
7. Developing alternative scanning methods that may further reduce or eliminate
eddy currents and their effects, such as radial scanning.
8. Development of predictive and “rule-of-thumb” equations for use in equipment
design.
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9. Build objective hardware simulators that can be used to “insert” test volumes and
determine the complete range of effects before the material is incorporated into a
design.
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APPENDIX

112

Maxwell 3D Design
This appendix describes the steps required to model and simulate the reference solenoid,
the bore coil, the gradient coils, and the MRI simulator used in this thesis. The various test
volumes and their modifications are also described.
Maxwell 3D is an electromagnetic field simulation tool used for the design of high
performance electromechanical components. It uses the finite element method for solving static,
frequency domain, and time varying electromagnetic fields. Use of Ansoft, Inc. documentation is
essential to creation and analysis of the MRI simulator.28, 29, 30, 31, 32, 33,34
It is important to note that significant performance enhancements can be achieved by:
1. Creating field plots and data tables after the analysis is completed. The interaction between
Maxwell 3D and Microsoft Windows creates a memory management problem that utilizes
significant computer resources and temporary files. If field plots and data tables are
established prior to initiation of the analysis, Maxwell 3D attempts to populate the data
during the course of analysis, creating a memory sharing problem. Allowing Maxwell 3D to
complete the analysis, then populate the field plots and data tables resolves this conflict and
allows the data to be populated many times faster.
2. Create reasonable meshes to separate the item of interest into the smallest number of
tetrahedral necessary to achieve results within the tolerance needed to extract meaningful
results.
3. Incorporate boundary conditions and dummy volumes to focus Maxwell’s interests to only
those elements needed.
4. Do not run parametric analysis on complex shapes as this creates its own memory
management problems that significantly reduce performance. Manually adjust individual
parameters as needed.
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Reference Solenoid
The reference solenoid is an arbitrary solenoid used to validate the mathematics of
Maxwell 3D for B field generation.

Bore Coil
For this simulation, the precise dimensions of the magnet are unimportant, but the
enclosed magnetic field is very important. In order to obtain a static magnetic field with a
sufficiently large space and a relatively uniform field, a cylinder of approximately 100 cm in
diameter and 200 cm in length was designed. The outer diameter of the bore magnet is set at 200
cm. This provides ample volume in which to insert test volumes of a size anticipated to be found
in most electronic or mechanical devices inserted into an MRI’s bore.

Project Setup
1. Open Maxwell 3D. A default project, Project1, should be loaded. If not, follow the next
steps, otherwise, skip to step 3.
2. Click File > New. This will create a new file with the default name Project1. A project is a
collection of one or more designs.
3. Click Project > Insert Maxwell Design. This will create a new design with the default name
MaxwellDesign1.
4. Click File > Save As. The Save As dialog box appears and allows the project to be saved
given a new name. Choose a name or use BoreCoil as the file name.
5. Right click on the Maxwell Design object in the Project Management window and rename
the object BoreCoil. Click Enter.

Environment Setup
1. Click Maxwell > Solution Type. The Solution Type window will appear allowing the
solution to chosen as Magnetostatic, Eddy Current, Transient, Electric, Electric –
Electrostatic, and Electric – DC Conduction. Choose Transient. Although the bore field is a
static field created by a uniform DC current in the bore conductor, the Magnetostatic solver is
not capable of generating time-varying excitations. Although the Eddy Current solver seems
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like a logical choice, it too is not capable of handling time-varying excitations. All solvers,
however, are capable of applying the eddy current effects to selected objects, therefore, the
transient solver is chosen to accommodate the time varying excitations of the gradient coils
and the eddy current effects are selected for the test volumes as described later.
2. Click 3D Modeler > Units. The default unit is the millimeter. This will be used throughout
the design.

Create Model Geometry
The bore coil is modeled by creating two cylinders of material that are subtracted from
each other to form a tube of material through which a DC current flows to create the MRI bore’s
static magnetic field. The exact strength of the field varies with different MRI machines. Here
1.5 T is used at the center of the bore field as the baseline.
Create Bore Magnet
1.
2.
3.
4.

Ensure the XY drawing plane is selected.
Click Draw > Cylinder. The cursor changes to a small black box indicating Drawing mode.
Select the center of the cylinder by clicking the (0,0,0) location in the 3D Modeler window.
Click any distance along the X or Y axis to create the radius of the cylinder. The exact
dimensions will be designated later and are not critical at this time.
5. Click any distance along the Z axis to create the cylinder length. The exact distances will be
designated next. When the cylinder length is created, a Properties window will appear.
6. Edit the radius and height of the cylinder in the Properties window. They are Radius = 1000
mm and Height = 2000 mm. Click OK. The cylinder created will most likely extend well
beyond the extents of the current 3D Modeler widow.
7. Click View > Fit All > All Views to resize the window to display the cylinder. The drawing
should be as shown in Figure 81.

115

Figure 81.

Cylinder

8. Click Draw > Cylinder to start the internal cylinder.
9. Select the center of the cylinder by clicking the (0,0,0) location in the 3D Modeler window.
10. Click any distance along the X or Y axis to create the radius of the cylinder.
11. Click any distance along the Z axis to create the cylinder length.
12. Edit the radius and height of the cylinder in the Properties window. They are Radius = 500
mm and Height = 2000 mm. Click OK.
13. Click View > Fit All > All Views to resize the window to display the cylinder, if needed.
The drawing should look similar to Figure 82.
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Figure 82.

Twin Cylinders

14. In the History Tree window, select Cylinder1. Press and hold down Ctrl and select Cylinder2.
Both cylinders should be highlighted in dark blue while the Maxwell window is active (grey
when Maxwell is inactive).
15. Click 3D Modeler > Boolean > Subtract to display the Subtract window. Two lists of parts
are displayed. The Blank Parts window lists the items that will remain after the operation
and the Tool Parts window lists the items that will be removed from the part. The result
should look like the drawing in Figure 83.
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Figure 83.

BoreCoil

16. Highlight Cylinder1 and edit the name in the Project Manager window to BoreCoil.
17. Click the box under the Material – Value cell to display the Select Definition window.
18. Scroll up the window to select copper as the material comprising the BoreCoil.
19. Click OK to close the window.

Create Bore Magnet Terminals
Create the Bore Magnet terminals. This will be used to define the DC current which
creates the static magnetic field.
1. In the History Tree window select the BoreCoil object.
2. Click 3D Modeler > Surface > Section to display the Section window. The YZ plane is an
appropriate plane to section the Bore Magnet. The XZ plane would work just as well, but the
XY plane is not appropriate.
3. Click OK to close the window. This creates one section object consisting of two rectangular
sections of the BoreCoil coil. The drawing should look like this:
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Figure 84.

Sectioned BoreCoil

4. Click the Section1 object in the History Tree window.
5. Click 3D Modeler > Boolean > Separate Bodies. This will separate the two section sheets
into Section1 and Section1_1. When applying the current, Maxwell inserts the current into
the entire sheet. If both sections remain part of the model, the two currents will be inserted
simultaneously, effectively cancelling each other. Therefore, only one section is required so
that the current circulates around the entire coil.
6. Click on Section1_1 in the History Tree window to highlight it.
7. Place the mouse over the Section1_1 object and right click to display the drop down menu.
8. Scroll down the menu and select Edit > Delete to remove the extraneous Section1_1 object.
Only the Section1 sheet object should remain. The BoreCoil should now look like this:
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Figure 85.

Single Section BoreCoil

Create the Background (Region)
The background region box defines the extents to which Maxwell 3D will partition the
region into finite elements. The magnetic field of an MRI exists in a region of space filled with
air. The background is designated to be air.
1. Click Draw > Box. Similar to the cylinder, the first, second and third dimensions of the box
are selected with the mouse. The exact dimensions are not critical as the Properties box will
be edited to describe the Background.
2. Edit the Position to be -2500, -2500, -4000. Xsize = 5000, Ysize = 5000, and Zsize = 5000
will define a box with dimensions of 5000 mm x 5000 mm x 5000 mm (16.4 ft. x 16.4 ft. x
16.4 ft.). These dimensions approximate the size of a typical MRI installation.
3. Click the Attribute tab in the Project Manager window.
4. Edit the name of the box to bgnd (“Background” is a reserved name in Maxwell 3D).
5. Click the box in the Material – Value cell to display the Select Definition window.
6. Scroll up the window to select “air” as the material in the bgnd box.
7. Click the “edit” box in the Color – Value cell to display the Color selection window. Edit as
desired.
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8. Click OK to close the Color window.
9. Click the box in the Transparent – Value cell to display the Set Transparency selection
window.
10. Set the transparency to 95%.
11. Click OK to close the Set Transparency window. The drawing should now look like this:

Figure 86.

BoreCoil Environment

Assign Excitations
A DC current is required in the BoreCoil to create the static magnetic field.
1. Using the various rotation and translation tools in the menu bar, position the drawing so that
the BoreCoil fills the design window.
2. Select Section1 in the History Tree window.
3. Click Maxwell > Excitations > Assign > Current from the menu to display the Current
Excitation window.
4. Edit the values in the window to name the current BoreCurrent with a value of 2,983,900
Amps. (This is really 2,983,900 Amps through 1 turn of the BoreCoil.)
5. Select Stranded as the Type and click the Swap Direction button until the vector indicates
the positive X direction. By choosing Stranded for the BoreCurrent Type, Maxwell creates a
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uniform distribution of current through the BoreCoil section area, simulating a multi-turn
solenoid. This will create current flow that produces a magnetic field that is positive in the Z
direction (right hand rule).
6. Click OK to close the window. The drawing should look like that shown in Figure 87.

Figure 87.

BoreCoil Current

Set Up the Analysis
1. Click on the “+” sign in front of the BoreCoil object in the Project Management window to
expand the properties of the design object.
2. Right click on the Analysis object and select the Add Solution Setup menu item to open the
Solve Setup window.
3. Click OK.
4. Select the Global:XZ plane in the History Tree window.
5. Right click on the Field Overlays object in the Project Management window.
6. Navigate the menu and select Field Overlay > Fields > B > Mag_B to display the Create
Field Plot window.
7. Use the default settings and click DONE to close the window.
8. Right click on the Analysis object and click on Analyze All.
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9. When Maxwell has completed the analysis, expand the Field Overlays object and click on
the Mag_B1 object to display the results. The resultant plot should look like this:

Figure 88.

BoreCoil Field Plot

Set Up the Data Collection
1. Navigate the menu and select Draw > Line to begin the process of drawing a line through
the volume where data is to be collected.
2. Maxwell will ask: A solution exists; do you want to create a non-model object? The answer
to this is “Yes.” Click the Yes button to continue.
3. Navigate down the “Lines” object to the Create Line item and edit the properties of the line.
In this case the data collected along the line will be down the z-axis of the BoreCoil, so the
endpoints of the line are 0,0,-500 and 0,0,1500, to give the line 500 mm of length above and
below the BoreCoil central volume.
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Gradient Coil
For this simulation, the dimensions of the gradient coil should match the bore magnet.
The gradient magnet will consist of 4 “saddle” coils positioned in such a manner as to add to the
strength of the magnetic field at the top and linearly decrease the field to the bottom.
Create Model Geometry
The gradient coil is modeled by creating two rectangles that are swept through an arc of
120 degrees and are subtracted from each other to form a saddle coil through which a DC current
flows to create the gradient coil’s magnetic field. The effect on the bore field is to create a linear
variation on the bore field of 1.0 Gauss per centimeter. This variation can only be simulated for a
small volume at the epicenter of the MRI simulator since. With the addition of shim coils, the
remaining gradient coils, and other more complex aspects of the MRI itself, a uniform gradient
field across all desired axes can be developed, but is beyond the scope of this thesis and is left to
future work.
Create the Gradient Magnet
1. The centerline of the BoreCoil is coincident with the Z axis, so we will develop the saddle
coils to also have a centerline along the Z axis. In the drawing menu bar, there is a dropdown box indicating the currently displayed drawing plane. Drop the box and select the YZ
plane.
2. Click Draw > Rectangle. The cursor changes to a small black box indicating Drawing mode.
3. Select a point on the YZ plane and drag a rectangle with the major length along the Z axis.
When completed, the Properties window will appear.
4. Edit the Position to be 0,1000,2001. This defines the starting position of the rectangle. We
are leaving a 1mm gap between the BoreCoil and the SaddleCoil.
5. Edit the YSize to be -100 and the ZSize to be 2000. The Y dimension will define the
thickness of the coils to be 100mm and the length to be 2000mm. The current in the arcs of
the SaddleCoil closest to the BoreCoil will create a magnetic field that contributes to the bore
field. The arcs furthest away from the BoreCoil are sufficiently far away as to have little
effect on the bore field. Similarly, a SaddleCoil at the opposite side of the BoreCoil will be
excited with current that subtracts from the BoreCoil field. The magnetic field between the
coils will vary to produce a linearly varying field in the volume of interest. Like the bore
field, the gradient fields will not be sufficiently modeled to simulate a true MRI field with
less than 5ppm variation across the entire bore, but will create the desired 1 Gauss per
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centimeter across the volume of interest, approximately a 5-inch cube at the epicenter. The
drawing should look like that shown in Figure 89.

Figure 89.

Gradient Coil Outer Rectangle

6. Click View > Fit All > All Views to resize the window to display the rectangle, if needed.
7. Click on the Rectangle1 object in the History Tree window.
8. Click on Draw > Sweep > Around Axis to display the Sweep Around Axis window.
9. Click on the Z axis radio button in order to sweep the rectangle around the Z axis.
10. In the Angle of sweep, replace the value with 65 to sweep the rectangle 65 degrees clockwise
from the Y axis.
11. The Properties window will display. Click OK to close. The drawing should look like this.
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Figure 90.

Gradient Coil Sweep

12. Click Draw Rectangle again and draw another rectangle right on top of the first rectangle.
This will create Rectangle2.
13. Click on Draw > Sweep > Around Axis to display the Sweep Around Axis window.
14. Click on the Z axis radio button in order to sweep the rectangle around the Z axis.
15. In the Angle of sweep, replace the value with -65 to sweep the rectangle 65 degrees
counterclockwise from the Y axis. The drawing will now look similar to this:
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Figure 91.

Gradient Coil Volume

16. Select Rectangle1. Select Rectangle2 by holding down the Ctrl button while clicking on
Rectangle2. Both rectangles should be highlighted in dark blue.
17. Select 3D Modeler > Boolean > Unite to combine both swept rectangles into one curved
plate.
18. It is important to use the same radius to create the second curved plate, so the first curved
plate must be moved. Click Rectangle1 in the History Tree window.
19. Click on the Move button in the drawing toolbar.
20. Select a starting point at 0,0,0 and an end point at 0,2000,0 to move the first curved plate
2000 mm away from the Z axis. (Any direction can be used, but the exact position must be
retained as the volume must be returned exactly to its starting position.)
21. Click Draw > Rectangle. The cursor changes to a small black box indicating Drawing mode.
22. Select a point on the YZ plane further away from the Z axis giving plenty of room to create
another curved plate and drag a rectangle with the major length along the Z axis. When
completed, the Properties window will appear.
23. Edit the Position to be 0,1000,2101. This defines the starting position of the rectangle.
24. Edit the YSize to be -100 and the ZSize to be 1800. The Y dimension will define the
thickness of the coils to be 100mm and the length to be 1800 mm. This will define the curved
plate that is subtracted from the first plate to form the saddle coil. The drawing should now
look like this:
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Figure 92.

Second Gradient Coil Rectangle

25. Click View > Fit All > All Views to resize the window to display the rectangle.
26. Click on the Rectangle3 object in the History Tree window.
27. Click on Draw > Sweep > Around Axis to display the Sweep Around Axis window.
28. Click on the Z axis radio button in order to sweep the rectangle around the Z axis.
29. In the Angle of sweep, replace the value with 60 to sweep the rectangle 60 degrees clockwise
from the Y axis.
30. The Properties window will display. Click OK to close.
31. Click Draw Rectangle again and draw another rectangle right on top of the first rectangle.
This will create Rectangle4.
32. Click on Draw > Sweep > Around Axis to display the Sweep Around Axis window.
33. Click on the Z axis radio button in order to sweep the rectangle around the Z axis.
34. In the Angle of sweep, replace the value with -60 to sweep the rectangle 60 degrees
counterclockwise from the Y axis.
35. Select Rectangle3. Select Rectangle4 by holding down the Ctrl button while clicking on
Rectangle4. Both rectangles should be highlighted in dark blue.
36. Select 3D Modeler > Boolean > Unite to combine both swept rectangles into one curved
plate.
37. Move the first curved plate back on top of the second curved plate by selecting Rectangle1.
38. Click Move.
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39. When the Properties window appears, ensure that the move is 0,-2000,0 to place the first
curved plate on top of the second curved plate. This is what the result should look like:

Figure 93.

Superimposed Gradient Coil Volumes

40. Click Rectangle1 and Rectangle3 using the Ctrl key to simultaneously select them.
41. Select 3D Modeler > Boolean > Subtract to display the Subtract window. Ensure that
Rectangle1 is in the Blank Parts area and Rectangle3 is in the Tool area. Click OK to
perform the subtraction and close the window. This completes on saddle coil. It should now
look like this:
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Figure 94.

Completed Gradient Coil

42. Right Click on the Rectangle1 object in the History Tree window and select Properties.
43. Rename the object to SaddleCoil1.
44. Ensure the SaddleCoil1 object is highlighted by clicking on it in the History Tree window.
45. Click on the Mirror Duplicate button in the drawing menu bar. Click on the 0,0,0 point to
start the mirror operation. Click along the negative Y axis to create the mirrored object. It
will be named SaddleCoil1_1. The drawing should now look like this:
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Figure 95.

Mirrored Gradient Coils

46. Rename the created object to SaddleCoil2.
47. Select both SaddleCoil1 and SaddleCoil2 using the Ctrl key.
48. Click on the Mirror Duplicate button in the drawing menu bar.
49. Click along the Z axis to create SaddleCoil1_1 and SaddleCoil2_1 along the Z axis. This will
position the second pair of coils 2001mm too far down the Z-axis. They will look like this:
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Figure 96.

Gradient Coils

50. Highlight both coils in order to move them back into position.
51. Move the coils toward the bore exactly 2000mm towards the bore. This will place them 1mm
away from the BoreCoil.
52. Rename SaddleCoil1_1 to SaddleCoil3 (The coil opposite of SaddleCoil1).
53. Rename SaddleCoil2_1 to SaddleCoil4. They will now look like this.
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Figure 97.

Completed Gradient Coils

54. Click the vacuum object under Objects in the History Tree window.
55. Right click and change the material to copper.
56. Scroll up the window to select copper as the material comprising the BoreCoil.
57. Click OK to close the window.

Create the Gradient Magnet Terminals
Create the Gradient Magnet terminals. This will be used to define the DC current which
creates the static magnetic field.
1. In the History Tree window select all four saddle coils, SaddleCoil1, SaddleCoil2,
SaddleCoil3, and SaddleCoil4.
2. Click 3D Modeler > Surface > Section to display the Section window. The YZ plane is an
appropriate plane to section the Gradient magnet.
3. Click OK to close the window. This creates four section objects consisting of two
rectangular sections of the appropriate SaddleCoil objects.
4. Click the Section1, Section2, Section3, and Section4, objects in the History Tree window.
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5. Click 3D Modeler > Boolean > Separate Bodies. This will separate the section sheets into
Section1, Section1_1, Section2, Section2_1, Section3, Section3_1, Section4, and Section4_1.
When applying the current, Maxwell inserts the current into the entire sheet. If both sections
remain part of the model, the two currents will be inserted simultaneously, effectively
cancelling each other. Therefore, only one section is required so that the current circulates
around the entire coil.
6. Click on Section1, Section2, Section3, and Section4 in the History Tree window to highlight
it.
7. Delete the highlighted sections.

Assign Excitations
An AC current is required in the SaddleCoil to create the time varying magnetic field.
1. Select Section1_1 in the History Tree window.
2. Click Maxwell > Excitations > Assign > Current from the menu to display the Current
Excitation window.
3. Edit the values in the window to name the current Current1 with a value of 1 Amps. (This is
simulated as 1,000,000 Amps through 1 turn of SaddleCoil1.)
4. Select Stranded as the Type and click the Swap Direction button until the vector indicates
the positive X direction. The excitation should look like this:
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Figure 98.

SaddleCoil1 Current

5. Click OK to close the window.
6. Select Section2_1 in the History Tree window.
7. Click Maxwell > Excitations > Assign > Current from the menu to display the Current
Excitation window.
8. Edit the values in the window to name the current Current2 with a value of 1 Amps. (This is
simulated as 1,000,000 Amps through 1 turn of SaddleCoil2.)
9. Select Stranded as the Type and click the Swap Direction button until the vector indicates
the positive X direction. The excitation should look like this:

Figure 99.

SaddleCoil2 Current

10. Click OK to close the window.
11. Select Section3_1 in the History Tree window.
12. Click Maxwell > Excitations > Assign > Current from the menu to display the Current
Excitation window.
13. Edit the values in the window to name the current Current3 with a value of 1 Amps. (This is
simulated as 1,000,000 Amps through 1 turn of SaddleCoil3.)
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14. Select Stranded as the Type and click the Swap Direction button until the vector indicates
the positive X direction. The excitation should look like this:

Figure 100.

SaddleCoil3 Current

15. Click OK to close the window.
16. Select Section4_1 in the History Tree window.
17. Click Maxwell > Excitations > Assign > Current from the menu to display the Current
Excitation window.
18. Edit the values in the window to name the current Current4 with a value of 1 Amps. (This is
simulated as 1,000,000 Amps through 1 turn of SaddleCoil4.)
19. Select Stranded as the Type and click the Swap Direction button until the vector indicates
the positive X direction. The excitation should look like this:
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Figure 101.

SaddleCoil4 Current

20. Click OK to close the window.

Field Calculator
The Field Calculator available in Maxwell 3D allows the user to perform a variety of
tasks beyond the built-in functions of Maxwell 3D. These post-processing and plotting
capabilities include vector operations, vector algebra, calculus, and can be fully scripted. The
calculation steps used to determine the current through a surface are:
1. Click Maxwell > Fields > Calculator from the menu bar. This will launch the Field
Calculator.
2. Under the Input column, click Quantity > J. This selects the current vector as a quantity to
be operated upon.
3. Also under the Input column, click Geometry > Volume > TwinLoop. This doesn’t really
contribute to the overall calculation, but indicates where to restrict Maxwell’s area of
interest, namely to that of the TwinLoop volume. This allows Maxwell to eliminate
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4.
5.
6.
7.
8.

calculation of the J vector for all model elements outside the realm of the TwinLoop and
significantly improves processing performance.
Under the General column, click Domain. This selection concludes the selection of the
TwinLoop as the domain of interest.
Under the Vector column, click Normal. This adds the normal vector to the equation.
Finally, under the Scalar column, click the button to complete the surface integral
calculation.
To complete the assignment of the equation, click the Add button and name the equation.
Click Done to exit from the Field Calculator.
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